VMwareWorkstation与DeviceCredentialGuard不兼容的解决方案

码农公社  210.net.cn   210是何含义?10月24日是程序员节,1024 = 210、210既 210 之意。

Workstation 15.5以及Workstation 16版本出来了都想尝尝鲜,便卸载之前的Workstation 版本下载新版本但是安装上报错不能用。

特么的,为啥不能用啊?

先说一下我的环境:

联系笔记本电脑:WIN10专业版操作系统,系统版本号:1909,BOIS中未开启虚拟化特性,windows功能未启用Hyper-v功能;下载的是VMware workstation15.5版本。

在我的这个环境中下载VMware workstation15.5并安装好,打开的时候会提示以下这个页面说

(VMware Workstation 与 Device/Credential Guard 不兼容,在禁用Device/Credential Guard后,可以运行VMware)。

1.jpg

这种时候该怎末处理呢?小杨百度了三天,用自己电脑按照各种方法实验了几十遍但是都没有解决,以下是我在网上搜集的各种解决方法链接,感觉这些方法较为靠谱大家可以参考一下:

https://blog.csdn_net/qq32933432/article/details/104472739/

https://blog.csdn_net/luckysign/article/details/101915064

http://www_win7zhijia_cn/win10jc/win10_20680.html

https://www.fujieace_com/vmware/device-credential-guard.html

但是用这些方法都没有解决这个问题;后来按照报错提示给出的链接(https://kb.vmware_com/s/article/2146361)去VMware官网查看了一下原因,具体电脑安装VMware workstation环境啥的小杨的电脑环境都一样。但是就是报错安装不上,最后在官网发现一条相关信息,则是VMware Workstation中对Windows支持的最低要求,我把具体情况拿了过来给大家参考:

这是链接(https://kb.vmware_com/s/article/76918?lang=en_US)


问题:

如果在启用Hyper-V和/或VBS的Windows主机上运行VMware Workstation 15.5.5或更高版本,则将使用Windows Hypervisor Platform技术启动VM。如果此技术的发行版本不是特定级别,或者Windows主机硬件不满足某些最低要求,则VM将无法启动。这些最低要求在下面的原因部分中进行了描述。

1.jpg


造成此问题的原因是系统不满足某些最低要求。


支持的主机操作系统 

Windows 10 20H1内部版本19041.264或更高版本

支持的工作站版本

工作站15.5.5或更高版本

主机系统的处理器要求

英特尔桑迪桥

AMD Bulldozer或更新的CPU


解析度

要解决此问题,请执行以下任一操作:

升级主机硬件和软件,以满足上面“原因”部分所述的最低要求。

在Windows主机中禁用Hyper-V,然后启动VMware Workstation并打开VM。

请注意,如果禁用了Hyper-V,则Windows主机VBS将自动被禁用

注意:

如果使用Windows 10 1909或更早版本,则无法满足系统要求,因此必须将“基于虚拟化的安全性”设置为“未启用”。

最后得出结论,是我们电脑自己的配置较低,win10操作系统 1909版本以及之前的版本只能安装VMware Workstation 15.1.0之前的版本, 当安装 VMware Workstation 15..5或者更高版本(如VMware Workstation 15pro、VMware Workstation 16)时候都会报错,当安装16版本闪退的时候可以将电脑管理员名称换个英文,或者启动超级用户就是Administrator那个就ok。


所以这时我们只能安装VMware Workstation 15.1及以下的版本了。这是以下是小杨同志在VMware官网下载的VMware Workstation 15.1版本转存在迅雷云盘里面了,下载速度相对可观,大家可以下载此版本,以下是分享的迅雷云盘的链接(链接:https://pan.xunlei_com/s/VMRSh3j31aMKqWPhI9fZoSGzA1   提取码:zn42)

此版本激活码:CG392-4PX5J-H816Z-HYZNG-PQRG2

VMware Workstation 15.1安装教程:

(https://www.cnblogs_com/yxmboke/p/14305166.html)

再来说一下Workstation 15.5pro和Workstation 16版本的新功能分别都有哪些

Workstation 15.5pro新增功能:

新增加了一些可安装的操作系统:

l  Windows 10 19H2

l  Debian 10.0/10.1

l  Debian 9.11

l  Oracle Linux 8.0

l  SLE 15 SP1

l  FreeBSD 12.0

l  支持巨型帧:现在,可通过大小不超过 9000 字节的 MTU 来配置虚拟网络。

l  保留网络配置:现在,在升级后会保留网络设置。您还可以导入和导出自己的网络配置。

l  多个显示快捷键:现在,可使用新的键盘快捷键来快速调整虚拟机的显示布局。

l  支持 PVSCI 设备:PVSCSI 适配器现已受到 Workstation 的正式支持,这可增强 Workstation 与 vSphere 之间的虚拟机迁移的兼容性。


Workstation 16新增功能:

该版本支持容器和Kubernetes、DirectX 11、OpenGL 4.1、USB 3.1、vSphere 7.0、暗黑模式等诸多新特性,但是对电脑本地硬件有要求:Windows主机,需要Win10 1809或更高版本且支持DirectX 11.0的GPU

l  运行Windows DirectX11游戏和应用程序

l  使用vctl进行运行、生成、推送或拉取OCI容器

l  支持在桌面上部署K8S环境

l  新增无障碍模式

l  新增VM规格,32vCPU、128G内存,8GVRAM

l  支持vSphere7本地和远程连接

l  优化VM操作性和文件传输能力

l  在隔离的沙盒中运行vGPU渲染引擎

l  支持暗黑模式

l  支持Windows Hpyer-V

l  支持最新版Windows 10和Linux最新版本(发行版本)

l  集成Linux Vulkan 渲染引擎


新增支持的OS:

RHEL 8.2

Debian的10.5

Fedora的32

CentOS的8.2

SLE 15 SP2 GA

FreeBSD 11.4

ESXi 7.0


但是听其他博主说VMware Workstation 16版本有一些bug,用的时候偶尔会有些问题。


具体咱们用虚拟机做实验或者生活中要使用的时候这些新增的功能咱们基本也用不到,所以还是老老实实的用我们之前使用的Workstation版本吧!!!!555555 


评论